Asset compilation problem with ckeditor

Hi there,

We have a problem in production with ckeditor. The problem is already present when our app was based on consul 0.16, still present after an upgrade to consul 0.17.

We have a customized toolbar with a “link” button. A click on the link button launches a pop up in development environment, but not in production environment. There seems to be an asset compilation problem, as reveals the following warning in javascript console :

Loading failed for the <script> with source “”

I tried to explicitely add the link plugin in ckeditor initializer ( but with no change.

I also tried to use my production config file in development, so as to reproduce the buggy behaviour, but didn’t manage. Even with the prod config file, on my machine everything worked as expected.

Do someone has any clue what we’re missing ?

This issue is still on the agenda. Any help, someone ?

(I’m desperate :cry:)

You can check this file and check if you initialize the plugin:

Thanks for your suggestion ! I had already updated CKeditor setup :

config.assets_plugins = %w[copyformatting tableselection scayt wsc link]

but that changed nothing.