Problem installing in new development environment for v1.0.0

Apache 2.4.6
Ruby 2.3.2
Consul 1.0.0
Memcached 1.4.15
Postgre SQL 11.13

I am trying to put a version 1.0.0 in and when doing bundle install it gives problems with mimemagic version 0.3.0,

this version no longer exists, it has been removed so it cannot be added, when I increase the version to the most old available, it indicates dependencies of higher versions of nokogiri, when increasing this it asks for new dependencies, until it asks me to increase version ruby to >= 2.5.0 and I would already be using a version higher than 2.3.2 that I should for consul 1.0 .0 with the consequent errors.
What can I do at this point?
If you continued with the steps that bundle is asking for, the ball of errors is increasing and the version upgrades of the gems also with the errors that this entails

Hi, @Alesander :smile:.

Please note you’re trying to install a version of CONSUL which is more than three years old and doesn’t have any of the bug fixes, security fixes and maintenance updates we’ve done since then. The latest version is version 1.5.0, which was released last week.

As you’ve noticed, versions prior to CONSUL 1.3.0 had a dependency on a version of mimemagic which is no longer available. In order to install version 1.0.0, you’ll have to apply these changes to the Gemfile.lock file first:

-    mimemagic (0.3.2)
+    mimemagic (0.3.8)
+      nokogiri (~> 1)

In any case, we recommend you install the latest version of CONSUL or, if that’s out of the question, a version as recent as possible.

Hope this helps!

Hi @javi
Thanks for your help, I need to make more changes with Gemfile.lock gem paperclip dependencies
Now I can run it correctly, now I will start with the update to the latest version, do I have to update one by one? or could you update to the latest version directly from 1.0.0?
PS: yes, I created an account and posted again because my user was blocked, thanks for unblocking and helping me

Hi, @Alesander :smile:.

In theory you don’t have to update the paperclip dependencies because Paperclip 5.2.1 depends on mimemagic (~> 0.3.0) and we’re installing 0.3.8, but I guess that may vary if you’ve added custom changes to your version of CONSUL :thinking:.

You need to upgrade versions one by one and make sure you read the release notes before each upgrade. For most versions, you only need to execute the bin/rake consul:execute_release_tasks RAILS_ENV=production command right after upgrading, but (as mentioned in the release notes) some of them might require additional steps depending on your installation.

If you were to directly upgrade to the latest version, you would lose data in the process. To give you an example why, we’ve just moved from Paperclip to Active Storage, but migrating existing attachments requires having both installed at the same time. So in version 1.4.0 we added Active Storage and provided a task to migrate existing attachments, and in version 1.5.0 we removed Paperclip. If you try to directly upgrade from version 1.3.0 to version 1.5.0, you won’t be able to migrate the existing attachments because Paperclip is no longer installed.

I’d also recommend waiting a couple of days between upgrades to check everything is working properly before moving on to the next one, but that’s entirely up to you :wink:.

P.S. Sorry for the blocking confusion! Our automatic spam filter gave a false positive and we didn’t see it earlier because of holidays.

Hi @javi
Thank you very much for your help, regarding paperclip, that’s how I understood it too, but the bundle update failed, so I had to change the version.
Okay, we will take it into account when updating, it is a task that has been delayed for a long time and now we must carry out numerous updates, I hope everything goes well.

Hi, @Alesander :smile:.

Just in case this is what you meant (not sure whether that’s the case), don’t run bundle update after applying the patch. Run bundle install instead.